Index
I can't install Kipi Plugins - Korganizer - Printable Version

+- Index (http://forums.netrunner.com)
+-- Forum: Netrunner (http://forums.netrunner.com/forumdisplay.php?fid=75)
+--- Forum: Software and Applications (http://forums.netrunner.com/forumdisplay.php?fid=76)
+--- Thread: I can't install Kipi Plugins - Korganizer (/showthread.php?tid=24104)

Pages: 1 2


I can't install Kipi Plugins - Korganizer - fanisatt - 15th April 2017

I am a MAUI user and I have just installed Netrunner (17.03) too.
It is a very nice Debian based distro !!!!
I can't install digikam , kipi plugins , kontakt - korganizer with package manager .
I download and run a digikam application image and it is working fine .
I don't know if I can install the above reported applications in the future after any updates.
Any help please ?
Best Regards !


RE: I can't install Kipi Plugins - Korganizer - starbuck - 15th April 2017

If you enable the Debian testing repo, can you install it then?


RE: I can't install Kipi Plugins - Korganizer - fanisatt - 15th April 2017

(15th April 2017, 14:07)starbuck Wrote: If you enable the Debian testing repo, can you install it then?

Thanks for your response !
I would prefer to wait for a normal and safe installation with the default repos without any risk.
Actually this is the second installation of netrunner 17.03 I have done.
Yesterday I did my first one and when I had the same problem with digikam , kontakt and kipi plugins I enabled the Debian testing repo and I took all the updates !!!!
Ok ... it was an immoderate action ... Ι screwed the system up ... but, I remember I could not finaly install these applications. Anyway I am just a user and not an experienced one...
Today I reinstalled the OS and I decided to be more carefull and much more patient...
Best Regards !


RE: I can't install Kipi Plugins - Korganizer - starbuck - 15th April 2017

What exactly happened when your first system screwed up?


RE: I can't install Kipi Plugins - Korganizer - fanisatt - 15th April 2017

(15th April 2017, 18:33)starbuck Wrote: What exactly happened when your first system screwed up?
The system did not boot / start with the normal way , only with the recovering procedure - every time.
I remember a message (during the recovery procedure) that the root was locked (something like that).
So I decided to reinstall.


RE: I can't install Kipi Plugins - Korganizer - Winux2000 - 16th April 2017

(15th April 2017, 9:19)fanisatt Wrote: I am a MAUI user and I have just installed Netrunner (17.03) too.
It is a very nice Debian based distro !!!!
I can't install digikam , kipi plugins , kontakt - korganizer with package manager .
I download and run a digikam application image and it is working fine .
I don't know if I can install the above reported applications in the future after any updates.
Any help please ?
Best Regards !

I posted a thread about an issue I had installing digikam in Netrunner Desktop 17.01, which was solved for that OS version. But seems digikam has install issues in this OS version, for me as well.

1 solution recommended & referenced in post #5 of; "[Solved] Digikam 5.3 unmet dependencies", would be to install an appimage of digikam (http://download.kde.org/stable/digikam/). (didn't work well for me, would freeze randomly and run slow). This may work well for other's, like it has for you.
------------------------------------------------------------------------------------------------------------------
I too, hope this can be solved... Here's some output, that I hope can help someone solve this.
Output from my Netrunner 17.03 OS
Code:
sudo apt-get install digikam -o "Debug::pkgProblemResolver=1"
[sudo] password for xxx:
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Starting pkgProblemResolver with broken count: 1
Starting 2 pkgProblemResolver with broken count: 1
Investigating (0) digikam-private-libs:amd64 < none -> 4:5.3.0-1 @un uN Ib >
Broken digikam-private-libs:amd64 Depends on libmarblewidget-qt5-25:amd64 < none | 4:16.08.3-1 @un uH > (>= 4:15.12.0)
 Considering libmarblewidget-qt5-25:amd64 0 as a solution to digikam-private-libs:amd64 1
 Holding Back digikam-private-libs:amd64 rather than change libmarblewidget-qt5-25:amd64
Investigating (0) kipi-plugins:amd64 < none -> 4:5.3.0-1 @un uN Ib >
Broken kipi-plugins:amd64 Depends on digikam-private-libs:amd64 < none | 4:5.3.0-1 @un uH > (= 4:5.3.0-1)
 Considering digikam-private-libs:amd64 1 as a solution to kipi-plugins:amd64 0
 Holding Back kipi-plugins:amd64 rather than change digikam-private-libs:amd64
Investigating (1) digikam:amd64 < none -> 4:5.3.0-1 @un puN Ib >
Broken digikam:amd64 Depends on digikam-private-libs:amd64 < none | 4:5.3.0-1 @un uH > (= 4:5.3.0-1)
 Considering digikam-private-libs:amd64 1 as a solution to digikam:amd64 9999
   Reinst Failed early because of libastro1:amd64
   Reinst Failed because of libmarblewidget-qt5-25:amd64
Broken digikam:amd64 Depends on kipi-plugins:amd64 < none | 4:5.3.0-1 @un uH > (= 4:5.3.0-1)
 Considering kipi-plugins:amd64 0 as a solution to digikam:amd64 9999
   Reinst Failed because of digikam-private-libs:amd64
Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
digikam : Depends: digikam-private-libs (= 4:5.3.0-1) but it is not going to be installed
          Depends: kipi-plugins (= 4:5.3.0-1) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

My active repos;
Code:
xxxx:~$ grep -r --include '*.list' '^deb ' /etc/apt/ | sed -re 's/^\/etc\/apt\/sources\.list((\.d\/)?|(:)?)//' -e 's/(.*\.list):/\[\1\] /'

[netrunner-rolling.list] deb http://deb.debian.org/debian/ testing main contrib non-free
[google-chrome.list] deb [arch=amd64] http://dl.google.com/linux/chrome/deb/ stable main
[opera-stable.list] deb https://deb.opera.com/opera-stable/ stable non-free
deb http://snapshot.debian.org/archive/debian/20170206/ testing main contrib non-free
deb http://ds9-eu.s3-website.eu-central-1.amazonaws.com/dci/packages/netrunner/ netrunner-1703 qt5 plasmazilla plasma netrunner netrunner-desktop kde-applications frameworks extras ds9-common ds9-artwork calamares backports
deb http://ds9-eu.s3-website.eu-central-1.amazonaws.com/dci/packages/netrunner/ netrunner-backports backports calamares ds9-artwork ds9-common extras frameworks kde-applications netrunner-desktop netrunner plasma plasmazilla qt5

Code:
apt-cache policy digikam
digikam:
 Installed: (none)
 Candidate: 4:5.3.0-1
 Version table:
    4:5.3.0-1 500
       500 http://snapshot.debian.org/archive/debian/20170206 testing/main amd64 Packages
       500 http://deb.debian.org/debian testing/main amd64 Packages



RE: I can't install Kipi Plugins - Korganizer - fanisatt - 16th April 2017

@ Winux2000

Thank you very much for your response !
I had read in your thread about the application image solution - I didn't know anything about these portable applications.
So , I tried the application image and it was working fine .
Anyway , I can't work with this OS anymore because of unusual graphics problems. Perhaps it is a Graphics card minor incompatibility (nvidia gt-710).
I changed many times the compositor version for opengl (3.1 or 2.0) to found the best solution but...nothing ! The PC could work fine for hours or for minutes (!!!) and suddenly my screen was unstable or the system was freezing. (Nouveau drivers)
I wanted 2 Linux OSs in two different disks !
As my main OS I have installed MAUI (it's the best OS today to my PC ) !
As an alternative OS I wanted to be the Netrunner but finally I had to install something else.
Best Regards !!


RE: I can't install Kipi Plugins - Korganizer - Winux2000 - 21st April 2017

Digikam package issues in 17.03, due to older package dependency.

With the custom snapshot release build of Netrunner 17.03, is there a newer Digikam package in Maui, Neon or somewhere, that can be ported to Netrunner Desktop 17.03?


Also, unable to post code without getting a spam error message for the post.



RE: I can't install Kipi Plugins - Korganizer - shadeslayer - 27th April 2017

I think the problem is that digikam needs to be rebuilt against the newer marble we released with KDE Apps 16.12

A temporary workaround for the time is:

Code:
sudo apt-get install digikam libastro1=4:16.08.3-1

This will remove marble, but you should be able to install the 16.08 version from synaptic just fine.


RE: I can't install Kipi Plugins - Korganizer - Winux2000 - 27th April 2017

Thanks for updating the repos! Digikam installed fine.

I also installed marble 16.08 with marble-plugins 16.08 (& locked version).
Otherwise, when you use synaptic to upgrade the system, it will upgrade marble-plugins & remove digikam.
Quote:digikam will be removed
digikam-private-libs will be removed
kipi-plugins will be removed
libmarblewidget-qt5-25 will be removed
libastro1 (version 4:16.08.3-1) will be upgraded to version 4:16.12.2-0neon+9+build11
marble (version 4:16.08.3-1) will be upgraded to version 4:16.12.2-0neon+9+build11
marble-plugins (version 4:16.08.3-1) will be upgraded to version 4:16.12.2-0neon+9+build11
libmarblewidget-qt5-26 (version 4:16.12.2-0neon+9+build11) will be installed

Version lock has no effect & is unnecessary when using command line to upgrade.
My preferred & safer upgrade method.
Code:
sudo apt-get upgrade
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
 libastro1 marble marble-plugins
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.